3.2 has arrived!

Yes, it’s patch day!


I actually had a problem getting it installed. You might get this error if you were on the PTR…

This update requiresWoW.exeversion You have an older version,

I uninstalled the PTR and it fixed it but I have also read running the launcher as an administrator might also fix the problem.

One Response to 3.2 has arrived!

Leave a Reply

Your email address will not be published. Required fields are marked *


Armory for Jacemoryl

Druid Blogs

Other Blogs